Installation af NemID-certifikat i Evolution mailprogrammet

| 7 Comments |
Lixtal: 42Middel: Dag- og ugeblade
  • aNyhed
  • Digg it!
  • Add to Technorati
  • Stumble It!
  • Google Bookmarks
  • Facebook
  • Facebook
Som konsekvens af, at DanID ikke kan finde ud af at supportere Linux ordentligt, idet de beder brugeren overskrive vigtige systemfiler samt binder brugeren til et mailprogram, der ikke er standard mailprogram i Ubuntu, må vi andre jo tage affære.

NB: Hvis du hellere vil installere NemID som en pakke i standard Ubuntu-format, har jeg sammensat en anden vejledning, der måske er lidt nemmere.

Jeg har derfor sat et script sammen, der foretager følgende:

1. Det sørger for, at Ubuntu har filer installeret på forsvarlig vis, så det kan undgås at overskrive filerne med DanIDs filer.

2. Det henter NemID-applikationen og installerer den.

3. Det starter NemID-applikationen, så brugeren kan hente sit NemID-certifikat.

4. Det installerer certifikatet således, at Evolution uden videre kan bruge det. Endvidere kan man bruge det til at underskrive dokumenter i LibreOffice.

Mit script, der kan benyttes frit, så længe det er i ikke-kommerciel sammenhæng, kan hentes her: installer-nemid.sh. Sørg for at give scriptet udføre-rettighed:

chmod 775 installer-nemid.sh
./installer-nemid.sh

Script'et vil bede om dit administrator-password, hvis ikke det finder de nødvendige filer. Der er ingen risiko forbundet med dette, hvilket kyndige Linux-brugere vil kunne forvisse sig om ved eftersyn af script'et.

Kære DanID: Det tog mig under to timer at finde ud af, hvordan jeg skulle installere jeres certifikat i Evolution samt skrive det ovenstående script. Og det tog få sekunder at gennemskue, at man ikke behøver kopiere filer ned i systembibliotekerne. Skam jer, at I ikke som mindstemål laver en .deb pakke, så afhængighederne udredes automatisk, og skam jer, at I ikke engang kan flikke et sådant script sammen.

7 Comments

Hey, har ikke lige prøvet dit script, men det ser ud til du installerer pakken "certutils" for at få modutil, men så vidt jeg kan se findes modutil i pakken "libnss3-tools".

Det ser ud til der har sneget sig lidt snask ind i starten af første linje af den nye udgave, bash er ikke så glad.

Forresten: Enig i kritikken af DanID, der findes fine standarder for certifikater, så det burde ikke være så besværligt...

Jeg tror jeg vil benytte dit script i min Ubuntu VM, så jeg kan signere emails. Det virker jo ikke på Microsoft Office x64.

hmm jeg må korrigere mig selv. Det virker SLET IKKE i Outlook 2010, uanset platformen.

Først undrede det mig lige, at du har forbudt kommerciel anvendelse af scriptet. Men så forstod jeg! :-)

Leave a comment

Ældre indlæg

Sider

Om dette indlæg

Denne side indeholder et enkelt indlæg af Ole Wolf, udgivet d. 29.06.2011 13:50.

Forrige indlæg: NemID går frem og tilbage over åen efter vand

Næste indlæg:NemID som .deb-filer

Find de nyeste indlæg på forsiden, eller søg i de ældre indlæg to find all content.